[Solved] Preview not working anymore after Edit&Save

Cardbook for Thunderbird Forums Main Forum [Solved] Preview not working anymore after Edit&Save

Viewing 10 reply threads
  • Author
    Posts
    • #3606
      Chris
      Keymaster

      After editing a contact, the preview function in the main window is not functioning anymore. It just shows nothing. For any contact and in any addressbook that is – not just the edited one. Can be reproduced anytime.

      My view is the threefold one with the addressbooks on the left, the contacts in the middle and the preview on the right side.

      Only way to get the preview back is to restart Thunderbird.

      I also had an issue with unsaved changes – but since I don’t remember if I did other changes inbetween and it didn’t happen another time so far, it may have been a mistake on my side. Will get back if I can reproduce this.

      74.6
      Thunderbird: 91.8.0 on Windows 10

    • #3607
      CardBook
      Keymaster

      Hi

      may you contact me by email (cardbook (at) cardbook.icu) to debug this ?

    • #3608
      Chris
      Keymaster

      It’s fixed in 74.7 – thanks a lot Philippe! 🙂

    • #3609
      Friedel
      Participant

      Hi,

      I still have the same problem with Version 74.8. (TB Vers. 91.8.1).

      Do I still have to do something?

      Friedel

       

    • #3610
      CardBook
      Keymaster

      Hi Friedel

      have you restarted Thunderbird ?, any issues in the Thunderbird console (CTRL+SHIFT+J) ?

    • #3611
      Friedel
      Participant

      For me, the situation is exactly the same as described by Chris. When I restart TB, everything is fine again. I just reprod the error and in the console came an error message:

      Unexpected event profile-after-change URLQueryStrippingListService.jsm:224
      observe resource://gre/module/URLQueryStrippingListService.jsm:224

      Should / can I post here the text that is behind the link?

      Friedel

       

    • #3612
      CardBook
      Keymaster

      this error is not for CardBook, may you try to disable others add-ons ? are you able to produce a reproducible test case ?

    • #3613
      Friedel
      Participant

      I have now reconstructed the error again. The same error message has appeared again as a new one. And: Under “Warnings” the following has been added:

      [l10nregistry] Attempting to synchronously load file
      resource:///chrome/en-US/locale/en-US/calendar/messenger/otr/otrUI.ftl while it’s being loaded asynchronously.

      To this I must say that since installing CardBook I have problems synchronizing. When starting TB and synchronizing, TB hangs for about half a minute. After that everything is done.

      Otherwise I have about 10 other Add:Ons. Should I disable all of them? That is time consuming, because I probably have to make new settings afterwards.

      Friedel

       

    • #3617
      Friedel
      Participant

      Hi,

      now I have worked on it again and deactivated all AddOns – at once. After that, the problem no longer occurred. Then I enabled all AddOns again and also now everything works. Very strange.

      One more correction to my note above about having problems with synchronizing: This does not affect CardBook, but only the calendar. So that doesn’t matter here.

      Friedel

       

    • #3620
      CardBook
      Keymaster

      If you might the culprit add-on, it would be nice !

    • #3624
      Friedel
      Participant

      Sorry I’m just now responding to your question, but I just saw it.

      I would like to tell you the culprit, but I don’t know it. As I had written, I had deactivated ALL add-ons at once and then reactivated ALL again. Therefore, I can not say who caused the problem. Since I have little time at the moment, I had saved myself the trouble of going through all of them again afterwards, especially since it worked again.

      Now after a few days it has unfortunately happened again. After I made a change in an address, the same problem happened again. In the TB Console has come the following message. Is this a message that concerns CardBook?

      Unexpected event profile-after-change URLQueryStrippingListService.jsm:224

      Also I have the following error:

      DataCloneError: The object could not be cloned.

      If you can’t do anything with the messages (I also still have the entire message behind the message), I have to deactivate the AddOns bit by bit, which is unfortunately time-consuming.

      Friedel

       

       

Viewing 10 reply threads
  • You must be logged in to reply to this topic.