[Solved] Empty or missing books at startup

Cardbook for Thunderbird Forums Main Forum [Solved] Empty or missing books at startup

Viewing 11 reply threads
  • Author
    Posts
    • #127
      Anonymous
      Inactive

      Hello,

      running Thunderbird 45.7.0 on Linux xUbuntu 16.10, I have sometimes one of these startup problems, or a mix of them :

      • one or multiple address books are missing
      • some address books are empty

      This is not a systematic issue but I haven’t been able to identify the use case, except launching TB. Probably a cache problem?

      I use multiple address books (5) which are connected to a ownCloud 9.1.1 (4) or Dolibarr (1). I deactivated the one connected to Dolibarr recently, but the problem remains.

      How to investigate?

      Best regards,

      Thomas

      • This topic was modified 5 years, 5 months ago by CardBook.
    • #128
      CardBook
      Keymaster

      in fact there when starting are two concurrent processes :

      1/ the load of data (address books and contacts) (and after the sync)

      2/ the display of the UI

      the second one is a bit delayed but it can happen that when the second is started the first one is not started or very partially started… so when this happen just close and reopen the CardBook tab…

    • #129
      Anonymous
      Inactive

      Thanks for the tip. I’ll try.

      But it still sounds strange because this morning I wanted to wrote an email to a regular contact, but it does not appeared in suggestions in “To:” field. I didn’t tried to access to UI at this moment but TB was launched since more than 30min. So my contact were not present in addresses books until I reload “Synchronize” in CardBook UI.

      Is it possible to activate some logs to check CardBook startup on my PC?

    • #131
      CardBook
      Keymaster

      yes : set the debug mode and increase the size of log (50000) in CardBook preferences and send me (cardbook.thunderbird@gmail.com) the CardBook log when you arrive to reproduce… check also if you have errors in the javascript console (CTRL+MAJ+J)

    • #142
      Anonymous
      Inactive

      Hello,

      got the problem this morning. Closing and reopening UI does not fix.

      Where are stored the logs?

      BR,

    • #143
      CardBook
      Keymaster

      just click on the text at the bottom right, in the CardBook tab

    • #144
      Anonymous
      Inactive

      Here are the ctrl+Maj+J trace :

      Horodatage : 16/02/2017 08:13:05
      Avertissement : Error: Script terminated by timeout at:
      cardbookSynchronization.getFilesFromDir@chrome://cardbook/content/cardbookSynchronization.js:924:1
      cardbookSynchronization.getFilesFromCache@chrome://cardbook/content/cardbookSynchronization.js:914:11
      cardbookSynchronization.loadCache@chrome://cardbook/content/cardbookSynchronization.js:935:22
      cardbookSynchronization.loadAccount@chrome://cardbook/content/cardbookSynchronization.js:2148:6
      cardbookSynchronization.loadAccounts@chrome://cardbook/content/cardbookSynchronization.js:2115:5
      ovl_synchro.lEventTimerSync.notify@chrome://cardbook/content/ovl_synchro.js:14:4

      Fichier source : chrome://cardbook/content/cardbookSynchronization.js
      Ligne : 924

       

    • #145
      CardBook
      Keymaster

      CardBook does not succeed in reading the cache files from an address book… do you know which address book is wrong ?… try to explore the cache…

    • #146
      Anonymous
      Inactive

      At startup, only 3 books on 4 are “created”, and 2 of them are feeded with only this error :

      2017.02.16 08:13:08:337 : cardbookSynchronization.cachePutMediaCard error : [Exception… “Component returned failure code: 0x804b000a (NS_ERROR_MALFORMED_URI) [nsIIOService.newURI]”  nsresult: “0x804b000a (NS_ERROR_MALFORMED_URI)”  location: “JS frame :: chrome://cardbook/content/cardbookSynchronization.js :: cardbookSynchronization.cachePutMediaCard :: line 599”  data: no]

      When opening UI, and clicking “Synchronize”, the 3rd book is feeded but the 4th does not appear. Still have the same error as above, and these ones repeated for each contact from the missing book :

      2017.02.16 09:33:50:564 : debug mode : file rewritten : /home/user/.thunderbird/gcuxfrtf.default/cardbook/87035090-bce7-43ef-b1fc-2e82a77e9543/d5740f02-51b7-4815-b938-c2f9540163f4.vcf
      2017.02.16 09:33:50:564 : Frigo : debug mode : Contact xxx written to cache
      2017.02.16 09:33:50:564 : cardbookRepository.addCardToRepository error : TypeError: cardbookRepository.cardbookAccountsCategories[aCard.dirPrefId] is undefined
      2017.02.16 09:33:50:565 : Frigo : Contact xxx récupéré du serveur

      From what I read, there are data in cache and card is retrieved from server, but matching with server seems not corresponding.

      Any idea? I you need full logs, give me your email.

      Thanks

    • #147
      CardBook
      Keymaster

      seems there is a problem with a photo of one or more contacts… try to remove photos if possible… if not I’ll send to you a test version

    • #148
      Anonymous
      Inactive

      ok for beta-testing. no emergency, it’s very nice to answer so quick

    • #149
      CardBook
      Keymaster

      I need your email (mine is cardbook.thunderbird@gmail.com)…

Viewing 11 reply threads
  • You must be logged in to reply to this topic.