[Solved] Content of second line of Google contacts address is not shown

Cardbook for Thunderbird Forums Main Forum [Solved] Content of second line of Google contacts address is not shown

Viewing 3 reply threads
  • Author
    Posts
    • #3634
      topoldo
      Participant

      Hi all.

      I’m using the latest version of Cardbook with Thunderbird 91.9. In these conditions if I fill a record of the addressbook in Google using both lines you can use for the address and than I sync this record with Cardbook, only the first line of the address appears in Cardbook.

      For example, suppose a record of Google contacts, whose content is:

      Name: John
      Surname: Doe
      Address (1st line): La Cittadella Business Center
      Address (2nd line): Via G. Bianchi, 9
      City: PADOVA
      ZIP Code 35100
      Country: Italy

      When you sync this contact with Cardbook and see which is the content in Cardbook, then you have:
      Name: John
      Surname: Doe
      Address: La Cittadella Business Center
      City: PADOVA
      ZIP Code 35100
      Country: Italy

      ie the content of the 2nd line of the address  is lost.
      I have no idea if it is a bug or a limitation in the compatibility between Google contacts record structure  Cardbook ones.

      Tnx for the attention.

      Cheers,
      Topoldo

      • This topic was modified 1 month, 1 week ago by Chris. Reason: Title adapted
    • #3636
      CardBook
      Keymaster

      investigating this tomorrow, thanks a lot for reporting ! 🙂

    • #3644
      CardBook
      Keymaster

      so the information is correctly parsed and is available into CardBook. To display it, in CardBook preferences, Tab pane, modify the address formula to display the Appartment field, maybe this formula is usefull : ({{3}}\n|)({{1}}\n|)({{2}}\n|)({{4}} |)({{6}}|)(\n)({{5}}\n|)({{7}}|)

    • #3645
      topoldo
      Participant

      Tnx a lot!

      The formula you provided seems to work.

      Topoldo

Viewing 3 reply threads
  • You must be logged in to reply to this topic.