Autocomplete and adding contacts from emails fails

Cardbook for Thunderbird Forums Main Forum Autocomplete and adding contacts from emails fails

Tagged: 

Viewing 13 reply threads
  • Author
    Posts
    • #2963
      AvatarAlienOrange
      Participant

      I love cardbook and your great work. It has worked flawlessly for years. Thank you so much!

      Unfortunately recently TB stopped to autocomplete emails addressed. The config has not changed and “autocomplete” is checked.

      Also adding a new contact using the context menu (right click on email “add to cardbook”) now shows a tiny box – instead of a menu of address books. (If it matters: I use local and remote CardDAV address books)

      It seams that the TB “connection” to cardbook is lost somehow. The cardbook tab itself works like always (I can add, search, auto-dial etc).

      I’ve tried to disable and re-enable the plugin, add/delete/disable/enable address books – all to no avail. Issue continues and is reproducible.

      I’m using TB 68.12.0 (32-bit) build 20200820223055 on Win10 (just upgraded but 68.11.0 had the same issue)

      Any help is highly appreciated. Thanks very much!

      • This topic was modified 3 months, 1 week ago by AvatarAlienOrange. Reason: Corrected TB version after upgrade
    • #2965
      CardBookCardBook
      Keymaster

      Hi

      is CardBook the unique source for autocompletion (CardBook preferences, first tab, first option) ?

    • #2972
      AvatarAlienOrange
      Participant

      Yes, Cardbook is the only source – and it has worked before.

      As I explained it’s not just the autocomplete but the whole connection to cardbook is lost. No more contact adding from Thunderbird and such. So “autocomplete” is just one symptom that probably has the cause somewhere else.

      As Thunderbird is mostly unusable without contacts I’m very desperate and I’ve even tried to recover Thunderbird’s profile (user/appdata/thunderbird) from backup completely. Unfortunately the backup is to old and Thunderbird doesn’t take it for some reason – starting with a new install.

      I can’t do a Thunderbird reinstall (as I have some 20 mailboxes) or a new config. But I only have one CardDAV source.

      So my now question is (unless you have a better solution), how can I remove Cardbook completely from Thunderbird to start all over (with cardbook) but leave everything else as configured in Thunderbird?

      Thanks much!

    • #2973
      CardBookCardBook
      Keymaster

      before doing that, have you got errors in the console after starting Thunderbird (CTRL+SHIFT+J) ?

    • #2976
      Avatarmaction
      Participant

      Hi there,

      Since this is my first post in this forum following registration: great add-on, thanks a lot! 🙂

      Every now and than I’m experiencing the same issue where autocomplete using CardBook stopped working. I didn’t spend any effort on investigations, so far. However, it might be related to some resource issues on the device (memory), i.e. there are heavy swap memory activities running in parallel. The only thing that helped so far was to restart TB. Following the restart autocomplete works again as expected.

      Latest configuration that failed in this regard was TB 68.12.0 (64-bit) and CardBook 45.3 where Cardbook is configured not to be the single source for contacts.

      Cheers
      Mac

      • This reply was modified 2 months, 1 week ago by Avatarmaction.
    • #2978
      CardBookCardBook
      Keymaster

      have you got a LDAP address book ?

    • #2979
      Avatarmaction
      Participant

      Hi,

      I’m not using LDAP but addresses collected by TB as the second option for autocomplete, in German called “Gesammelte Adressen”.

      If I remember correctly, when autocomplete stopped working no addresses have been offered from neither source. With this, the/my issue might even not be related to CardBook but to TB – just my two cents.

      Cheers,
      Mac

    • #2985
      Avatars-light
      Participant

      Hello @all,

      thanks for the Add-on!!

      i also encountered this behavior:
      sometimes if i write a new mail there are no addresses shown.
      for some time now i have CardBook as only source (but the setting is checked)

      my feeling was that it had to do with network problems – so if my network was not reachable it screwed something up…

      just now i did a restart of thunderbird and the new cardbook version was installed – then the autocompleten in a new mail worked all fine.

      if the problem pops up i will check the console and report back.

      thanks for your support and your time creating cardbook!!!
      i use it a lot!!

      sunny greetings
      stefan

       

    • #2986
      CardBookCardBook
      Keymaster

      Hi

      thanks :O)

      if you smell a network issue, this can’t be CardBook as it does not do connections except during sync…

      When CardBook is updated, yes it requires a Thunderbird restart to work…

       

      Philippe

    • #2995
      Avatars-light
      Participant

      ok today it happened again.
      there were some errors in the console about sync problems..

      after i cleared the console and waited some time (have done other things not in Thunderbird) it just worked again.

      are there any things i can do to debug this some more / get closer to what triggers it?

      sunny greetings
      stefan

       

    • #3023
      Avatars-light
      Participant

      hey 🙂

      just this moment the bug appeared again.
      and this time i found something with help of the developer tools:

      11:16:53.124 console.log("open new mail now!")
      11:16:53.149 open new mail now! debugger eval code:1:9
      11:16:53.146 undefined
      11:17:11.913 NS_NOINTERFACE: Component returned failure code: 0x80004002 (NS_NOINTERFACE) [nsISupports.QueryInterface] stack-trace-collector.js:84
      11:17:12.037 window.controllers/Controllers is deprecated. Do not use it for UA detection. blank

      at least the two lines at the bottom popped up in the moment  i open a new mail window.
      but this is not reproducible…

      in the log Viewer there were only entries from the sync process shortly after my mail opening. – so i changed the stored log-lines to 500 so that maybe next time i have more info available.

      after a restart of TB it worked again.

       

    • #3024
      CardBookCardBook
      Keymaster

      I think this was due to the last CardBook version update which requires a Thunderbird restart…

    • #3031
      Avatars-light
      Participant

      ah ok – so the automatic update occurs – i don’t notice this – and after the update it does not work till i restart…

      sound very possible 😉
      is it possible to show a big message in the logs after update?
      or is the message there but i did not see it? ;-)…..

       

    • #3032
      CardBookCardBook
      Keymaster

      yes there is no warning…

Viewing 13 reply threads
  • You must be logged in to reply to this topic.